this post was submitted on 11 Oct 2023
35 points (92.7% liked)

Programming

17017 readers
560 users here now

Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!

Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.

Hope you enjoy the instance!

Rules

Rules

  • Follow the programming.dev instance rules
  • Keep content related to programming in some way
  • If you're posting long videos try to add in some form of tldr for those who don't want to watch videos

Wormhole

Follow the wormhole through a path of communities !webdev@programming.dev



founded 1 year ago
MODERATORS
top 17 comments
sorted by: hot top controversial new old
[–] AnUnusualRelic@lemmy.world 9 points 11 months ago (1 children)
[–] marcos@lemmy.world 7 points 11 months ago (1 children)

That deserves an "always has been" meme... But IMO, Ruby outperled Perl since the beginning.

Perl doesn't let you redefine the syntax so that you can write the same program multiple ways. All it does is to encourage multiple programs to have the same meaning.

[–] AnUnusualRelic@lemmy.world 3 points 11 months ago (1 children)

I never looked at Ruby, but that doesn't seem like it would be great for readability (although maybe productivity).

[–] marcos@lemmy.world 1 points 11 months ago

People mostly refrain from using it.

Much like people used to create an idiom in Perl and stick to it.

[–] eager_eagle@lemmy.world 3 points 11 months ago* (last edited 11 months ago)

The liberty to not name things that are obvious.

and that's yet another way to end up with hard to read code.

Variables hold values that have meaning. Learn how to name things and you'll write good code.

[–] twelvefloatinghands@lemmy.world 2 points 11 months ago (4 children)

Damn, I wish rust had that

[–] colonial@lemmy.world 11 points 11 months ago (2 children)

It wouldn't be as relevant, since passing a function or method instead of a closure is much easier in Rust - you can just name it, while Ruby requires you to use the method method.

So instead of .map(|res| res.unwrap()) you can do .map(Result::unwrap) and it'll Just Work™.

[–] jendrik@discuss.tchncs.de 3 points 11 months ago (1 children)

Except when Type::Method takes a reference, then it doesn't just work

[–] colonial@lemmy.world -1 points 11 months ago* (last edited 11 months ago)

Well, that's to be expected - the implementation of map expects a function that takes ownership of its inputs, so you get a type mismatch.

If you really want to golf things, you can tack your own map_ref (and friends) onto the Iterator trait. It's not very useful - the output can't reference the input - but it's possible!

I imagine you could possibly extend this to a combinator that returns a tuple of (Input, ref_map'd output) to get around that limitation, although I can't think of any cases where that would actually be useful.

[–] vidarh@lemmy.stad.social 1 points 11 months ago* (last edited 11 months ago)

In the case of your example we'd do .map(&:unwrap) in Ruby (if unwrap was a method we'd actually want to call)

Notably, these are not the cases _1 and _2 etc are for. They are there for the cases that are not structurally "call this method on the single argument to the block" e.g. .map{ _1 + _2 } or .map { x.foo(_1) }

(_1 is reasonable, because iterating over an enumerable sequence makes it obvious what it is; _1 and _2 combined is often reasonable, because e.g. if we iterate over a key, value enumerable, such as what you get from enumerating a Hash, it's obvious what you get; if you find yourself using _3 or above, you're turning to the dark side and should rethink your entire life)

[–] TheCee@programming.dev 8 points 11 months ago

I'm glad it doesnt.

[–] paperplane@lemmy.world 3 points 11 months ago

Swift does, though using the dollar sign rather than underscores

[–] Anders429@programming.dev 1 points 11 months ago

I sincerely doubt Rust would ever add something like this.

[–] Knusper@feddit.de 2 points 11 months ago

I do think the unnumbered variant of such anonymous parameters is useful, if you've got a team of devs that knows not to misuse them.

In particular, folks who are unexperienced will gladly make massive multi-line transformations, all in one step, and then continue blathering on about it or similar, as if everyone knew what they were talking about and there was no potential for ambiguity.

This is also particularly annoying, because you rarely read code top-to-bottom. Ideally, you should be able to jump into the middle of any code and start reading, without having to figure out what the regional abbreviations or it mean.

[–] jeffhykin@lemm.ee 1 points 11 months ago (1 children)

Is it just me or does it feel kinda unclean for it to just support 1 through 9?

[–] eager_eagle@lemmy.world 1 points 11 months ago

tbf positional arguments are already bad enough. Now if you're using over 9 positional args... just take a break, go for a short walk, and maybe you'll come back with a better plan

[–] bnjmn@programming.dev 1 points 11 months ago

OMG looks like Raku