this post was submitted on 26 Aug 2023
249 points (88.1% liked)

Linux

48008 readers
1194 users here now

From Wikipedia, the free encyclopedia

Linux is a family of open source Unix-like operating systems based on the Linux kernel, an operating system kernel first released on September 17, 1991 by Linus Torvalds. Linux is typically packaged in a Linux distribution (or distro for short).

Distributions include the Linux kernel and supporting system software and libraries, many of which are provided by the GNU Project. Many Linux distributions use the word "Linux" in their name, but the Free Software Foundation uses the name GNU/Linux to emphasize the importance of GNU software, causing some controversy.

Rules

Related Communities

Community icon by Alpár-Etele Méder, licensed under CC BY 3.0

founded 5 years ago
MODERATORS
top 17 comments
sorted by: hot top controversial new old
[–] fubo@lemmy.world 51 points 1 year ago (1 children)

Fortran, really.

In Fortran, variables beginning with the letters i through n have integer type by default, whereas all other letters imply a real-number (floating-point) variable. You can change this by declaring a type, but using i for a real is non-obvious.

(Hence the old joke, "God is real — unless declared integer.")

Interesting. I assumed i for iterator.

[–] juliebean@lemm.ee 44 points 1 year ago (2 children)

in programming, and in mathematics, it's always been weird to me that frequently paired variables are basically the most easily confused for one another pairs, especially when written quickly or sloppily.

  • i and j
  • x and y
  • m and n
[–] reverendsteveii@lemm.ee 7 points 1 year ago

I think your problem is with the alphabet, friend

[–] Sam@sh.itjust.works 25 points 1 year ago

I always like to joke in coding interviews that I really like to make variable names as long as I can so they are very precisely named. Then when I get to a double nested loop I hit them with iterator and jiterator instead of I and j

[–] eager_eagle@lemmy.world 17 points 1 year ago* (last edited 1 year ago) (2 children)

Unless they're indices, do yourself a favor and use meaningful names instead.

I avoid index iterations the most I can tbh. And for nested loops,i and k is more readable.

[–] fidodo@lemm.ee 10 points 1 year ago

Even for indexes I do index or something more specific for what it's indexing. Any simple iteration I just do map or each so the only time I ever need to actually index things is for more complex scenarios in which case it's worth it to have better names. Also with modem IDEs, auto complete is really good so you don't need to write a full variable name more than once.

[–] reverendsteveii@lemm.ee 5 points 1 year ago

When I was a baby coder back in the 90s we were taught that these names were meant to save space in the symbol table because at one time space was so limited that naming your variable n rather than numElementsInArray would have an impact

[–] GodIsNull@feddit.de 11 points 1 year ago* (last edited 1 year ago)

i for index or iteration. Using j, k, l... in loops signals (imho) that there is most likely an outer loop and the one using j, k, l are nested. x and y of course are carthesian coordinates . n is used as amount of substance in SI-unit-system, m is mass, maybe thats why it is used as amount of items in a set (Menge).

Programming computers have started to solve mathematical problems and math already used these symbols for centuries(?), so why you should change them? They are well established even in simple school mathematics. And at the end of the day a computer is nothing more than a calculator.

[–] CommunityLinkFixer@lemmings.world 6 points 1 year ago (1 children)

Hi there! Your text contains links to other Lemmy communities, here are correct links for Lemmy users: !programmerhumor@lemmy.ml

I assumed i for iterator

[–] db2@sopuli.xyz 6 points 1 year ago

x = "Am I a joke to you?";

[–] A10@kerala.party 5 points 1 year ago (1 children)

I haven't used I and J after college

[–] Knusper@feddit.de 3 points 1 year ago

I've hardly ever looped over indices after college. For-each loops solve 99% of real-world problems in a better way.

[–] youRFate@feddit.de 3 points 1 year ago* (last edited 1 year ago)

Usually variables like that can be avoided with itterators nowadays. If they can’t I like to use idx, if they are nested I name them after what they index, like idx_rows, idx_cols.

[–] kent_eh@lemmy.ca 3 points 1 year ago

I prefer to use K in for loops, but that's just me.