this post was submitted on 01 Sep 2023
254 points (96.4% liked)

Programming

16999 readers
78 users here now

Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!

Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.

Hope you enjoy the instance!

Rules

Rules

  • Follow the programming.dev instance rules
  • Keep content related to programming in some way
  • If you're posting long videos try to add in some form of tldr for those who don't want to watch videos

Wormhole

Follow the wormhole through a path of communities !webdev@programming.dev



founded 1 year ago
MODERATORS
you are viewing a single comment's thread
view the rest of the comments
[–] hellishharlot@programming.dev 21 points 1 year ago (8 children)

Using single character variable names is always bad practice

[–] anon_8675309@lemmy.world 6 points 1 year ago (1 children)

Always and never are always bad.

[–] DahGangalang@infosec.pub 2 points 1 year ago

Counter point:

Always and Never is never bad.

[–] space_comrade@hexbear.net 6 points 1 year ago* (last edited 1 year ago)

Counterpoint: using anything other than 'i' as your index in a for loop in C or C++ is obnoxious as fuck.

At most I'll go with 'it' for C++ iterators.

[–] jvisick@programming.dev 6 points 1 year ago

Mostly agree. I’m ok with single characters in a one line / single expression lambda, but that’s the only time I’m ok with it.

[–] Double_A@discuss.tchncs.de 5 points 1 year ago

Unless you are implementing some mathematical formula. Then link the paper and stick to its variables.

[–] morrowind@lemmy.ml 3 points 1 year ago (1 children)

Sometimes you're just using it once and it's blindingly obvious what it is

[–] tryptaminev@feddit.de 2 points 1 year ago

To be fair everyone with poor documentation thinks the code is blindingly obvious when they write it.

[–] Chingzilla@lemmy.world 3 points 1 year ago

Hope you don't write go :D

[–] verstra@programming.dev 3 points 1 year ago (1 children)

I have a convention to correlate the size of variable scope with its name length.

If a variable is used all over the program, it will be named "response". If it is <15 lines, then it can be "res". If it is less than 3 lines, it can be only "r".

This makes reading code a bit simpler, because it makes unimportant, local vars short and unnoticeable.

[–] hellishharlot@programming.dev 4 points 1 year ago (2 children)

Why though? Intellisense helps you write out the full name. And instead of response why not call it whatever the data you're expecting to be

[–] lemmyingly@lemm.ee 2 points 1 year ago

I agree because it makes the code easier to follow in 6 months time.

[–] JuneFall@hexbear.net 1 points 1 year ago

Could you comment a couple of examples? At best some that signifiy the importance with them as verstra wrote.

[–] uralsolo@hexbear.net 2 points 1 year ago

I understand this conceptually, but there's also a gremlin in my brain that wants me to make every line as short as possible.